HTTP request length exceeds MaxRequestLen

nach dem update eines debian auf squeeze gabs bei einem upload in wordpress immer einen “500 internal server error” und im apache error log stand dann sowas:

mod_fcgid: HTTP request length 131538 (so far) exceeds MaxRequestLen (131072)

das liegt daran, dass unter lenny dieser wert (MaxRequestLen) noch 1GB war und seit squeeze nur noch 128kb. abhilfe schafft eine weitere zeile in der datei /etc/apache2/mods-available/fcgid.conf, welche den wert setzt:

<IfModule mod_fcgid.c>
    ...
    FcgidMaxRequestLen 134217728
    ...
</IfModule>

den wert sollte man so machen, wie es die php.ini erfordert:

upload_max_filesize = 128M
post_max_size = 128M

12. August 2012 by sd
Categories: Uncategorized | Tags: , , | Leave a comment

Leave a Reply

Required fields are marked *