firebox x500 mit pfsense

nachdem ich mir heute ein serielles kabel ausleihen konnte, hab ich mich mal an die installation der firebox gewagt. aber erst musste ein wenig an der hardware geschraubt werden. die compactflash karte muss raus und der dummy wechselrahmen samt seiner merkwuerdigen backplane, damit spaeter die 2,5 zoll platte installiert werden kann. ausgebaut sieht das so aus:

die 2,5er platte habe ich erstmal an einen beliebigen anderen rechner angeschlossen und mit der pfsense live cd gebootet… irgendwo (ich habs mir leider nicht gemerkt) konnte man dann die installation auf festplatte auswaehlen. husch ausgewaehlt und beim zu installierenden kernel den “embedded without vga and keyboard” (oder so aehnlich) ausgewaehlt. die standardinstallation laeuft ohne grossartige weitere fragen durch.

nun muss die platte in die firebox verbaut werden. provisorisch hab ich erstmal ein kleines brettchen in den schacht gelegt, damit die nicht einfach so auf der elektronik rumliegt. sieht etwas komisch aus… ist es auch… aber das mach ich noch anders 😉

nun einen rechner mit mit dem seriellen kabel dranstoepseln, hyperterminal starten und eine neue verbindung (mit den einstellungen: BPS: 9600 / Data bits: 8 /
Parity: None / Stop : 1 / Flow control: Hardware) anlegen.

nach dem anschalten sollten das im hyperterminal irgendwann so aussehen:

da die festplatte nun in einem anderen computer laeuft, hat sie eine andere bezeichnung, weshalb das freebsd die partition nicht mounten kann. an diesem prompt gibt man dann folgendes ein:

ufs:ad2s1a

…und drueckt enter. nun startet das pfsense ganz normal. damit man per webinterface darauf zugreifen kann, muss man nun die minimalste konfiguration per konsole machen. also die netzwerkkarten den pfsense interfaces zuordnen und die gewuenschte lan ipadresse einstellen.

damit der naechste reboot auch noch funktioniert, muss die datei “/etc/fstab” angepasst werden. mit der console und vi ist das quasi nicht so einfach, weshalb man das besser bzw. komfortabler im webinterface macht. die schritte dazu im menue: diagnostics -> edit file -> load /etc/fstab. darin die partitionen ad2s1a und ad2s1b eintragen, speichern und gut.

ich war selbst ueberrascht, wie vergleichsweise einfach das ging. naja… darf ja auch mal was klappen 😉

wen es interessiert, hier noch die ausgabe von dmseg dieser kiste: dmesg.txt

demnaechst will ich noch das lcd display dazu bewegen, wieder irgendwas anzuzeigen… momentan dient es nur der beleuchtung des kellers. fuer heute wars das aber erstmal…

11. August 2010 by sd
Categories: Uncategorized | Tags: , , | 3 comments

Comments (3)

  1. Hallo, ich versuche das gerade auch. Nur habe ich Probleme mit Laufwerken großer 2GB.
    Welche Biosversio hast du drauf?
    Ich hab T14 2003-10-29 Version AA
    Er findet ddas Segate ST1 2,5 GB Microdrive richtig im Bios, aber nach einem Reboot ist es wieder “weg”.

    Danke und Gruß

    Michael

  2. uff… äh… sagst du mir, wo ich schauen soll, dann mach ich das 😉
    ich hab z.b. nie ne grafikkartedran gehabt.

  3. Ohne VGA wird das leider nix 🙂
    Aber sie scheint nur ein Problem mit der Microdrives zu haben.
    Die 20GB HDD geht.

    Danke und Gruß Michael

Leave a Reply

Required fields are marked *