diaspora pod update wiedermal (2)

…wieder, damits irgendwo geschrieben steht. wer weiss, fuer was man das nochmal gebrauchen kann.

beim letzten mal hats ja schon nicht so recht klappen wollen. (fuer mich ist es) jedesmal wieder ein krampf. einfach nicht meine welt… naja…

beim update kam es bei diesem schritt…

DB="mysql" bundle install --without development,test

…zu dieser fehlermeldung:

Using markerb (1.0.0) from https://github.com/plataformatec/markerb.git (at master) 
ArgumentError: invalid byte sequence in US-ASCII
An error occured while installing markerb (1.0.0), and Bundler cannot continue.
Make sure that `gem install markerb -v '1.0.0'` succeeds before bundling.

oh.. ja.. die locales waren nicht richtig eingestellt. mal schnell nachholen und auf en_US.UTF-8 einstellen:

dpkg-reconfigure locales

dann kam es zu diesem fehler:

Installing rubygems-1.8.17 for ruby-1.9.3-p125@diaspora ...
Error running 'GEM_PATH="/home/diaspora/.rvm/gems/ruby-1.9.3-p125@diaspora:/home/diaspora/.rvm/gems/ruby-1.9.3-p125@global:/home/diaspora/.rvm/gems/ruby-1.9.3-p125@global" GEM_HOME="/home/diaspora/.rvm/gems/ruby-1.9.3-p125@diaspora" "/home/diaspora/.rvm/rubies/ruby-1.9.3-p125/bin/ruby" "/home/diaspora/.rvm/src/rubygems-1.8.17/setup.rb"', please read /home/diaspora/.rvm/log/ruby-1.9.3-p125@diaspora/rubygems.install.log
Installation of rubygems did not complete successfully.

was einfach deher ruehrte, dass in diesem pfad nichts installiert war…

/home/diaspora/.rvm/rubies/ruby-1.9.3-p125/bin/

warum auch immer… also einmal neu installieren.

rvm reinstall ruby-1.9.3-p125

ahja.. deswegen ists nicht installiert.. weil autoreconf fehlt:

rvm requires autoreconf to install the selected ruby interpreter however autoreconf was not found in the PATH.

also autoreconf installieren:

apt-get install dh-autoreconf

und dann klappts auch mit dem…

rvm reinstall ruby-1.9.3-p125

und das update wie bereits hier beschrieben laeuft durch… yeah 😉

su - diaspora
git pull origin master
DB="mysql" bundle install --without development,test
RAILS_ENV="production" DB="mysql" bundle exec rake db:migrate
bundle exec rake assets:precompile

UPDATE: oh.. und diesmal war ich richtig schnell und bin ohne fremde hilfe ausgekommen 😉

PingdomAlert UP:
https://pod.sd.vc (pod.sd.vc) is 
UP again at 03.07.2012. 09:39:36, after 45m of downtime.

03. July 2012 by sd
Categories: Uncategorized | Tags: , , | Leave a comment

Leave a Reply

Required fields are marked *